Make USB Hardware Problems History with this Handy ‘Quick Fix' Guide

With the information in this article you can:

- Discover the five essential elements to a successful USB connection.
- Resolve your own USB problems without needing expensive help from ‘experts'.
- Understand the USB hardware on your PC and how to ensure compatibility with future purchases.

There are two faces to USB. Firstly, it is the great success story of the computing world. A common interface that allows the interconnection and daisy chaining of computer peripherals. No more problems with having the wrong cable, USB will solve them all. This is great in theory but any telephone support service for PC users will tell you just how frequently USB can become a problem. USB is astonishingly close to perfect (for a computer product!), but that makes it even more unexpected when things do go wrong. This article provides a basic introduction to USB. It also gives detailed information on troubleshooting. With all of this under your belt, you should be able to go on regarding USB as the great success that it is, rather than as the problem that it can be.

Dr Steve North:
“USB is a significant step forward in standardising the interfacing of PC components. Particularly its user-friendly ability to ‘hot-swap’. Of course, nothing is perfect and the tips in this article should get you started on the road to diagnosing and solving USB problems for yourself.”

- Easily solving USB hardware errors........................................ U 5/2
- Simple steps to avoid USB problems....................................... U 5/5
- Hunt down the source of the error using the Windows System Event Log...................................................... U 5/6
- Solve USB power problems.................................................. U 5/6
- 3 more great ways to find and fix USB problems............ U 5/8
- Use these 3 free tools for USB diagnosis......................... U 5/9
Easily Solving USB Hardware Errors

The Universal Serial Bus (USB) is a hardware interface standard that allows users to plug a device into a USB port and have it automatically configured and ready to use. For most people, USB makes computer use a much simpler process. Compatible devices include: keyboards, mice, joysticks, scanners, printers, cameras and external drives (both Flash key fobs and conventional hard disks). In fact, there has recently been an explosion of unlikely (and often pointless!) devices that connect via USB.

Suitable devices may be ‘hot-swapped’, without the need to restart your PC. USB devices may be plugged into a USB socket on the PC, into a multi-port USB hub or into a USB device that also functions as a hub for other devices. In addition to data transfer, USB also provides a limited power supply. This may be utilised by peripherals that would normally require a separate mains adapter.

USB versions and speeds

There are three versions of USB: USB 1.0, USB 1.1 and USB 2.0. Each release has a faster maximum data speed than its predecessor. In order to make use of USB, your PC will need a Host Controller Card. This card consists of the controller itself and a root hub. It usually plugs into a standard PCI socket in your PC – you may already have one built into your PC’s motherboard.

All USB connections are considered to be between hubs. Each hub may have several ports for connecting devices. The root hub resides inside your computer and usually provides two or more ports, visible as USB sockets on the outside casing. Older Host Controller Cards may only support USB 1.0 or 1.1. Recent cards will support all three versions. In theory, up to 127 devices may be attached to a single Host Controller Card. The available maximum data speed (or bandwidth) and power supply are split between a card’s ports and its attached devices.
The important thing to understand is that additional Host Controller Cards may be added to your PC. Each new card will provide a new set of ports/sockets, more power and additional bandwidth. Many new PCs will have at least two Host Controller Cards. USB connections have three possible data speeds:

- Hi-Speed 480 Mega bits per second (Mbps)
- Full-Speed 12 Mbps
- Low-Speed 1.5 Mbps

These are often loosely associated to the three versions of USB: 2.0 (Hi-Speed), 1.1 (Full-Speed) and 1.0 (Low-Speed). Whilst this is generally true, it should be noted that a device may sometimes be labelled by a manufacturer as ‘USB 2.0 Full-Speed’. This means that it is compliant with the USB 2.0 specification, but only has a maximum data speed of 12 Mbps. A more accurate relationship between USB speed and version is:

- USB 2.0 supports Hi-Speed, Full-Speed and Low-Speed
- USB 1.1 supports Full-Speed and Low-Speed
- USB 1.0 Low-Speed

There are two types of software drivers for Host Controller Cards: one for Hi-Speed and another for combined Full-Speed/Low-Speed. These are usually displayed in Windows Device Manager (see page U 5/7) as:

- Enhanced PCI to USB Host Controller (for Hi-Speed)
- Open or Universal Host Controller (for combined Full-Speed/Low-Speed)

Therefore, a modern USB 2.0 Host Controller Card will need two drivers, to support all three speeds. An older card will only have one driver.

**Compatibility**

The most commonly asked compatibility queries may be answered as follows:
In most cases, hardware from different USB versions can be used together. It will only run as fast as the slowest device or controller.

Most USB 2.0 devices will work with an older USB 1.1 Host Controller Card, but they will run at only 12 Mbps (Full-Speed), instead of 480 Mbps (Hi-Speed).

Most USB 1.1 devices will work with a newer USB 2.0 Host Controller Card, but they will run at only 12 Mbps (Full-Speed), instead of 480 Mbps (Hi-Speed).

However, you should always check with a device manufacturer before assuming that your old USB 1.1 peripheral will definitely still work with a replacement USB 2.0 card.

PCs that support USB
Most computers that were manufactured after 1995 have USB ports. Desktop and laptop PCs sold after 2002 are very likely to have the hardware and drivers for USB 2.0.

Windows USB support
As almost all PCs now support USB 2.0, it is surprising to realise that NO current version of Windows actually supports USB 2.0 ‘out-of-the-box’. However, in most cases a PC running Windows XP and purchased recently, should already have the necessary software updates to support USB.

The following table explains the source of USB support for the various Windows versions:

<table>
<thead>
<tr>
<th>Windows version</th>
<th>Source of USB 1.1 support</th>
<th>Source of USB 2.0 support</th>
</tr>
</thead>
<tbody>
<tr>
<td>XP</td>
<td>Built-in</td>
<td>XP Service Pack 1</td>
</tr>
<tr>
<td>2000</td>
<td>Built-in</td>
<td>2000 Service Pack 4</td>
</tr>
<tr>
<td>Me</td>
<td>Built-in</td>
<td>Manufacturer of Host Controller</td>
</tr>
<tr>
<td>98SE</td>
<td>Built-in</td>
<td>Manufacturer of Host Controller</td>
</tr>
</tbody>
</table>
Simple Steps to Avoid USB Problems

To connect your USB device, five basic system elements must be present and working correctly:

- USB support from your PC’s BIOS.
- USB support from the version of Windows used.
- A working Host Controller Card with ports.
- The correct USB cable for the device.
- Software drivers either from Windows and/or the peripheral manufacturer.

Verify all of the following to get your USB device working:

- Check all connections.
- If your USB device requires software, always install it before plugging-in the peripheral. Windows Plug & Play should then find the required software.
- Check the power consumption and whether Windows Power Management is causing problems (see page U 5/7).
- Check if USB is disabled in your PC’s BIOS (restart Windows, press your machine-specific BIOS key and check for USB entries that need enabling).
- Check if a USB data cable is too long or is defective (see page U 5/8).
- Is a USB port on the front of the PC case not properly connected to the motherboard?
- Does an IRQ resource conflict exist between the USB port and another device? If so, uninstall your device and start again.
- The device may not be powered up. Some peripherals have a switch or setting to choose the power source. Select AC if the device is using a mains adapter and select DC if the drive is receiving power from the USB port.
Hunt Down the Source of the Error Using the Windows System Event Log

When something goes wrong with USB in Windows XP/2000, it is likely to be recorded in the System Event log. This may provide clues as to the original cause. To use Event Viewer when looking for USB errors:

2. Double-click Event Viewer.
4. Scroll down the list looking for any red entries with Error next to them.
5. If the time stamp of one or more events roughly coincides with your USB problem, double-click on each Error for more information.

Solve USB Power Problems

USB supplies 5 Volts (V) DC of regulated power that can be used by attached devices. Each root hub port/socket can provide a maximum current load of 500 milliAmps (mA). When further un-powered (or bus-powered) hubs are daisy-chained from a single port, all additional ports will have to share the 500 mA. As a single device may be capable of requiring 500 mA, the supply does not go very far. Where there is insufficient power available, a device may become erratic, or completely refuse to respond. There are two things to look for and these are shown in the following subsections.

Please note that the method shown for viewing USB hardware in the Windows Device Manager is equally applicable to all types of USB diagnostic investigation.
Checking the current load on a port

To find out how much power the attached devices are using (these steps are not available in Windows 98):

2. Click on the + next to Universal Serial Bus controllers, to display the relevant drivers.
3. Right-click on a USB Root Hub entry and then click Properties > Power (Properties > Power > Power in Windows Me). Note the values for total power available and required.
4. Repeat the last step for any further USB Root Hub entries.

If the power required exceeds the power available, the following approaches may be useful:

- Use a powered extension hub (or enable the power adaptor if this is a hub that can be bus or adaptor powered).
- Use a power adaptor for the device (changing any relevant power source settings that it may have). Not all devices will offer this option.
- Plug the device directly into another port on your PC, rather than a port on an extension hub.

Power management problems

If your device regularly fails to respond after it has been connected for a while, Windows may be sending it to sleep permanently. To resolve this:

2. Click on the + next to Universal Serial Bus controllers, to display the relevant drivers.
3. Right-click on a USB Root Hub entry and then click Properties > Power Management.
4. Un-tick Allow the computer to turn off this device to save power.
5. Click OK.
6. Repeat steps 3–5 for any further USB Root Hub entries.

3 More Great Ways to Find and Fix USB Problems

Cables
The electrical design of USB limits the maximum cable length to 5 metres for Hi-Speed/Full-Speed devices and up to 3 metres for Low-Speed devices. Nearly all USB 1.0 and 1.1 cables will work with USB 2.0. Cables for the latter are backwardly compatible with earlier USB versions.
You can use extension cables and up to 5 external USB hubs connected together to extend Hi-Speed USB’s range up to 30 meters. The distance between each hub must be no more than 5 meters.

External hubs
You can increase the number of USB ports on your PC, using external USB hubs in a similar way to adding a multi-way mains adaptor to a mains socket. Bus-powered hubs derive all of their power from USB. Other hubs are powered from their own mains adapter. Many can be switched between the two power modes. The following are tips for using external hubs:
• A powered hub is always preferable to a bus-powered hub.
• USB 1.1 hubs will work fine on USB 2.0 ports, but they cannot utilise USB 2.0 capabilities. They will default to slower speeds.

• Hi-Speed and Full/Low-Speed USB devices can co-exist nicely on USB 2.0 hubs. Connecting such a hub to a USB 2.0 port is recommended. Note: some hubs restrict the speed to that of the slowest device attached.

• USB 2.0 hubs can be used on computers with older USB 1.1 controller cards.

• Many USB devices do not work well on external hubs. Cameras, scanners and especially hard drives are known to have problems with external hub connectivity.

Ports
A basic ‘rule of thumb’ for USB ports is that when a device is not recognised, or does not work properly, try connecting it to a port on the PC (rather than one on a hub). However, it should be noted that some PC cases include front USB ports that are not connected! You might have noticed that some devices are treated as unrecognised when plugged into a different port. This is because not all hardware vendors store a unique serial number on the device.

Without this value, Windows will create a new reference for the device each time that the port is switched. It is usually best to get this out of the way by sequentially hot-swapping your peripheral between the available ports. Once all of them are familiar with the device, you should not see this problem.

Use these 3 Free Tools for USB Diagnosis
The tools in this section are all compatible with Windows XP/2000/Me/98SE. They can be found on the CD accompanying this article.
USB Info 1.3
This tool will optimise your USB devices and speed up the performance of Windows. You will also be able to verify that your devices really are USB 2.0 compatible. In the trial version, performance testing has been disabled, but you can still use USB Info to investigate your USB host controllers, root hubs and devices.

USB Info in action
To get started with USB Info:

1. Connect your USB Devices.
2. Start USB Info.
3. Click Continue Running Trial Version For Now and Buy USB Info Later.
4. Click Close on the Startup Quick Help window.
5. In the USB Device View and Selection For Performance Test window, look under Topology View of Connected USB Devices. You may need to use the horizontal and vertical scroll bars to see all of the information.
6. In the USB Device View and Selection For Performance Test window, click Help > Open User’s Manual. Note: you will need the latest version of Acrobat Reader to view this PDF file.
7. On page 16 of the User’s Manual, you will find a key to the symbols that are displayed next to devices in the USB Device View and Selection For Performance Test window. From this you can determine which USB version your device is capable of (2.0, 1.1 or 1.0) and its maximum speed (LOW, FULL or HI). You might realise that you have a Hi-Speed device connected to a USB 1.1 controller. If you also have a 2.0 controller, you will get improved performance by moving the device to a port on the faster controller.

8. You can find out more about your USB setup under Installed Devices In Registry View (Alternative Views), by clicking either Show Installed USB Devices In Registry View or Show Advanced Technical Info and Summary.

9. For a demonstration of the performance testing available in the full version of USBINFO (using dummy values), move to the Performance Test and Information Utility window and click Start Real-Time Test.

**UVCView**

The tool shows the tree of all USB hubs and connected devices and each device’s descriptors, with additional support for USB video devices.

The Windows Explorer-like presentation of UVCView shows, in the left-hand pane, your controllers, the hubs and the devices that are connected to the USB bus on your system. In the right-hand pane you get a full report of each item’s current status as you select it in the left-hand pane.

**SnoopyPro**

SnoopyPro allows you to record each data message sent and received by a USB device. To try this for yourself:
Once you have installed a 'snooper', you may need to use the target device, in order to log its USB activity.

1. Start SnoopyPro.
2. In the USB Devices window, click File > Unpack Drivers.
3. Click OK.
4. Click File > Install Service.
5. From the list of root hubs and devices, right-click on a device that you would like to test.
6. Click Install and Restart. In the Snooper installed? column, you should now see the entry Installed. A log window should open.
7. To test a selected device, try to perform a function with it. For example, if it is a USB printer, print a test page.
8. In the log window, you can study the individual data messages being exchanged over the USB bus. Clicking on + will expand the information. A detailed discussion of interpreting the messages is beyond the scope of this article, but you can search on the Internet for further information.
9. To remove the snooper from the device: right-click on it and click Uninstall and Restart.

That's it! You now understand the fundamentals of USB devices and how to troubleshoot them. The next step on the USB development ladder is Certified Wireless USB 1.0, which was approved in May 2005. Finally, please remember that some USB devices should not be unplugged without ‘stopping’ them first. Generally, printers, scanners etc. are fine but hard/flash drives may corrupt data that they are transferring. Before unplugging a device, first click the green Safely Remove Hardware icon in the System Tray (next to the clock).